wordpress 添加文章浏览历史功能

2019年3月10日19:13:17 4 558

如果想增加调用访客最近浏览过的文章功能,可以使用Last Viewed Posts这个插件,但由于这个插件很久没更新了,使用高版本的php及wordpress存在兼容性问题,可以按以下方式修改:

高版本的php不支持preg_replace,需要将

替换为:

修改完之后后台添加时报“无效值”错误,可以将

及zg_lwp_init方法代码改为extends WP_Widget的方法来初始化小工具,代码如下:

本文已通过「原本」原创作品认证,未经作者授权请勿直接转载,负责将依法追究其法律责任。
匿名

发表评论

匿名网友

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

评论:4   其中:访客  4   博主  0
    • 天空SKY 天空SKY 0

      感谢~升级后一直困扰的BUG在你这里解决了

        • 夏日阳光 夏日阳光

          @ 天空SKY
          很开心能帮助到你。

            • 虫子君 虫子君 0

              @ 夏日阳光 大佬你的这个代码高亮是插件还是代码实现的,可以共享一下吗,都是使用begin主题的

                • 夏日阳光 夏日阳光

                  @ 虫子君 我用的是 Crayon Syntax Highlighter 这个插件。